workfolder.note

noteId: WEBfb5809b5519d4bd8b4a34d529441b846 · 原始路径:/ALL/世赛题目(练习) - 笔记/第48届/08-集训队解题/B/workfolder.note · 图片:18 · 附件待处理:0

 
1、更改 WorkFolder端口:
 
(1)先停止 WorkFolder服务:
 
 
(2)修改workfolder配置文件:
我们没有权限修改该文件,需要取得所有权,并给予administrator修改的权限
# 路径:
c:\windows\system32\SyncShareSvc.config
 
先给予administrator写的权限:
 
 
然后编辑配置文件,修改端口号:
 
建议80 端口和 443端口都要修改,只改一个的话,另一个还是会冲突
 
最后需要输入一条命令才能生效
# 为Local SERVICE用户添加预存端口,允许他们监听指定的端口:
netsh http add urlacl url=https://*:1443/ user="NT Authority\Local SERVICE"
## 建议 80和443都修改,这样才不会和网站冲突
省略掉 NT Authority 也是可以的,会自动被补全
 
 
 
 
(3)同时修改 IIS服务器,Web服务器也必须要有一个相同端口号的 https接口:
必须绑定证书,这里绑定的证书是给 WorkFolder使用的
 
并且该网站不能启动:
 
 
(4)最后启动 workfolder服务:
如果服务启动失败,大概率是跟Web端口冲突了,停掉Web的站点即可
 
 
 
 
暂时不需要对端域访问:
 
将对端域的组添加到本地组,然后workfolder允许该组:
只能使用域本地组