配置failover使用 iscsi磁盘作为后端磁盘.note
一、配置 failover使用 iscsi磁盘:
注意不能安装多路径,安装多路径会出问题
1、配置iscsi磁盘共享:
不用安装多路径
允许两个failover IP即可:

2、配置 failover:
(1)两台failover机器将 iscsi磁盘挂载并初始化(不要进行格式化):
注意这里一定不能勾选使用多路径,否则后续failover会报错

然后对这块iscsi磁盘进行初始化(注意不要进行格式化)
(2)创建 failover集群:
两台集群服务器安装failover:

直接创建集群:

添加要加入集群的机器:

接下来会询问验证集群配置,验证配置花费的时间较久,我们选择不验证:

自定义集群名称,并自定义IP地址,这个名称和IP地址如果题目没有要求就无所谓:

接下来的配置都是默认,然后点击下一步
集群创建完成
此时就会有一个集群IP:

(3)在集群中手动添加该磁盘:

如果没有就点击refresh
(4)将该磁盘设置为维护模式,并在diskmgmt.msc中手动格式化该磁盘:

然后根据 Owner Node这里,在相应的一台机器上手动格式化这块iscsi磁盘即可
然后关闭维护模式
最终就可以看到这块磁盘:

之后就可以使用这块磁盘配置角色了