配置 ADRMS.note
# 配置步骤:
1、选择一个用户作为adrms管理用户(不能是administrator),将其加入Domain Admins,并设置邮箱
2、安装 adrms并选择该用户。
3、(重要)第一次配置完成adrms后一定需要 logoff,重新登陆administrator
4、配置成功。注意:adrms站点必须要有一个默认的443站点(不能书写域名,否则会报错“404”)

一、配置 单台 ADRMS(使用 windows内部数据库):
·需要准备一个 office 套件

·注意:
adrms的域用户账户,不能够是administrator
如果adrms在域控上,那么adrms的这个域用户账户需要加入 domain admins 组(或者 本地 administrators 组)
adrms的所有 用户、组 都需要有邮箱1、先安装CA根证书颁发机构,并申请一张证书:
操作这里不赘述
如果adrms的域名是使用那台机器的主机名,那么就只需要安装CA,然后使用CA默认颁发的计算机证书即可。
如果是题目指定了域名,那么就需要申请一张 web 或者 计算机证书。
2、安装 adrms:

直接下一步,安装即可
执行其它配置:

创建adrms集群

使用 windows 内部数据库

创建一个用户,并加入 Domain admins 组:

设置刚刚创建的用户:
这个用户不需要登陆,也不需要设置邮箱地址,创建加组后直接使用即可

加密方式无所谓,输入密码:



需要注意,如果是域名,那么就需要手动添加dns解析,使其能够访问
·域名和证书这里,如果前面是使用主机名作为域名,可以使用CA默认颁发的计算机证书

否则就需要去手动申请一张证书,这里我们手动申请了一张web证书,选择这张证书:
证书申请操作这里不赘述

接下来的操作就默认,然后安装即可

配置完成后,这里提示必须要注销然后再重新登陆
安装成功后打开 adrms管理器,如果报错是正常的,此时 logoff 一下重新登陆administrator即可:



logoff 重新登陆administrator,重新打开即可:


没有任何报错,那么就是正常的
3、客户端 加域 并安装 office:
加域操作不赘述
安装 office:


关闭安全限制,否则无法安装:
win + i





4、应用 adrms:
(1)先给要测试的用户添加邮件地址:

(2)在 word 文档中应用adrms:
客户端上打开 word 文档,随便输入内容,然后另存为,打开这个另存为文件:





如果是这个,就再点一次(如果多次都是这样,就logoff)
然后再点回去,就会有两个:
unrestricted access //不限制访问
restricted access //限制访问这里点击 restricted access:

然后就可以自定义允许访问、写入的 域用户了:


保存

·测试,logoff登陆其它用户打开该文件:
这个用户也是需要有邮件地址
受保护的文件如果离开了域,也是无法被打开的


5、自定义adrms模板(可选):
打开adrms管理控制台

如果打开报错,那么可以logoff,重新登陆administrator用户,重新打开
·创建模板:

添加名称和描述:

添加要允许使用的用户和组:
用户和组都必须有 email address字段


直接点击完成
·测试:
登陆 rms 组的用户,创建一个 word 文档保存,然后打开info页面:
可以看到刚刚创建的模板:

点击使用,然后保存即可
此时如果登陆其它用户(非rms组的用户),那么将无法访问这个文档


6、配置 SSO(可选):
当需要输入密码时,自动输入当前用户
(1)windows 10:
在 ie 浏览器中配置即可打开ie浏览器:





输入 adrms 的网址(不需要加 https、http)

此时logoff,再次访问 word文档时就会自动输入身份认证了
这里没有弹出认证提示框

(2)windows 11:
应该是需要在 edge 浏览器中配置二、配置多台ADRMS(需要数据库服务):
一般不常考,就算考了,也只安装两台单独的 ADRMS 即可,不关联,也不做集群