Zabbix报错合集.note
一、报错解决:
1、zabbix网页乱码:

·原因:
# apache2 没有开启 php8.2-fpm 或 proxy_fcgi:·解决方法:
a2enconf php8.2-fpm
a2enmod proxy_fcgi
systemctl restart apache2
2、点击next setup 报错:

·原因:
# php8.2-fpm的配置不符合zabbix的最小要求·解决方法:
# zabbix服务器上:
vim /etc/php/8.2/fpm/php.ini
# date.timezone 要求与本机时区相同
# max_input_time Zabbix最小要求为300
# max_execution_time Zabbix最小要求为300
# post_max_size Zabbix最小要求为16M



systemctl restart php8.2-fpm
3、报错 无法创建配置文件:

·原因:
# Zabbix的配置文件默认生成到 /etc/zabbix 目录下,而此时zabbix没有写入权限就会报错·解决方法:
chmod -R 777 /etc/zabbix //给予写入权限4、客户端通过zabbix引导后点击完成报错“权限拒绝”:

·原因:
# 与上一个原因类似,上一个原因是因为目录没有创建文件的权限,解决后,能够创建文件了,但是zabbix对于它自己创建出来的配置文件没有访问权限·解决方法:
chmod -R 777 /etc/zabbix5、zabbix-server 服务启动不了:
·原因:
我们 vim /log/var/zabbix-server/zabbix_server.log 能够查看到zabbix不支持当前mysql版本,它最高支持版本为 101099,而当前mysql版本为 101111
·解决方法:
# 配置 zabbix_server.conf 允许高版本的数据库:
vim /etc/zabbix/zabbix_server.conf
或者安装mysql时,指定版本,安装 10.10.99 以下的版本
6、Zabbix Server not running:

·原因:
1、/etc/zabbix/zabbix_server.conf 文件中没有指定 mysql 用户的密码
2、zabbix-server 服务默认是没有启动的·解决方法:
vim /etc/zabbix/zabbix_server.conf
systemctl restart zabbix-server

7、在安装zabbix时出现 Unsupported charset or collation for tables时:
