配置 failover clustering+.note

noteId: WEB91a1d4ed6700a84a881386a865a27074 · 原始路径:/ALL/Windows - B模块/服务配置/failover clustering/配置 failover clustering+.note · 图片:86 · 附件待处理:3

 
一、配置 failover:
在两边同时添加两块磁盘,一块 1G,一块50G(这两块可以是iSCSI挂载过来使用的)
 
1、配置 磁盘:
不管该磁盘是通过什么方式挂载的,只要有两块磁盘即可
 
在两边 关机添加两块磁盘,一块1G作为仲裁磁盘,一块50G作为数据磁盘:
 
将磁盘格式化,并创建简单卷:
 
2、创建 集群:
如果要配置有Hyper-V的集群,建议先安装Hyper-V再创建集群,因为安装Hyper-V有可能导致集群IP掉了,无法连接上
 
集群会自动将空间小的磁盘用作仲裁磁盘,将空间大的磁盘用作数据磁盘
 
 
 
创建一个 failover 集群:
 
 
 
 
创建成功
 
·查看状态
使用 ipconfig查看,能够查看到有一个 tunnel接口 和 集群的ip:
如果一台机器没有集群IP,那么就是在另一台机器上
 
能够看到有两块磁盘:(一块仲裁磁盘,一块数据磁盘)
此时配置成功,只需要再加上 Hyper-V 即可
 
 
 
 
 
 
 
二、配置 failover配置 iSCSI服务器:
# 前置条件:
1、Failover 不能安装和添加集群节点在域控上(否则部署Failover失败、启用S2D失败)
2、Failover 需要配置网关(否则部署Failover失败)
3、S2D只支持的磁盘类型(SATA、NvMe),不支持SCSI
 
部署过程:
1、正常部署Failover集群
2、在每个节点服务器上添加物理磁盘使其online(两边配置)
3、启用S2D(两边配置)
4、使用存储池创建虚拟磁盘
5、为ISCSI服务创建故障转移集群
 
 
1、先配置 failover:
两边安装 failover:
 
打开 failover:
 
创建一个 failover 集群:
 
 
 
 
·查看状态:
 
2、再添加物理磁盘(只需要 online,不需要格式化为物理卷)
使用 shutdown -s -t 0 关机机器添加(不要使用强制关机)
 
将两边的磁盘 online:(只需要online,不需要进行其它操作)
 
 
3、在两边都启用 S2D:
# 有两条命令,作用都是一样的:
Enable-ClusterS2D
Enable-ClusterStorageSpacesDirect
 
 
·查看状态:
原本的磁盘会被融合到 存储池中变得不可见
将会有一个 SDDC 角色
 
会有一个 虚拟磁盘(多的那个是该实验中手动创建的,不影响)
 
会有一个 cluster pool
 
4、使用 自动创建的存储池创建一个虚拟磁盘:
 
(1)图形化创建(只能够设置 ReFS格式):
创建的过程不赘述,创建虚拟磁盘后需要根据该虚拟磁盘创建简单卷
 
 
 
(2)命令创建:
# powershell
New-Volume -StoragePoolFriendlyName "S2D on CLS-Storage" -FriendlyName "storage" -FileSystem NTFS -Size 75GB -DriveLetter Z
 
 
 
·查看磁盘:
最后创建出来的磁盘是这样的:
 
 
5、配置 iSCSI服务器:
 
(1)安装 iSCSI:
两边都 安装 iSCSI、扩展iSCSI、iSCSI多路径:
 
 
 
(2)在集群上创建 iSCSI:
 
点击下一步
 
·查看状态:
两边都会各有一个IP,iSCSI IP,failover IP
 
 
 
 
6、配置 仲裁磁盘:
只有偶数节点时才需要配置仲裁,奇数节点时不需要配置仲裁(当前环境就是偶数节点,两台机器)
 
在其他机器上创建一个共享文件夹:(在其它设备上,如果在failover设备上的话,机器down掉就访问不到了)
 
 
配置仲裁:
 
 
 
 
 
 
 
7、(可选)配置 failover 优先级:
如果题目定义一台设备为主设备,并开启抢占,就需要配置
因为failover当一台设备down掉时,存储会自动迁移到另一台设备上,但是当down掉的设备up时,存储却不会自动迁移回来,配置该配置后就能够使其自动迁移到主设备上
 
在主设备上配置:
 
右键存储,点击属性:
 
使用 up、down 设置优先级,定位最优先,下面最不优先
这里的 High 表示角色启动的顺序,不是两台Server谁作为主备
 
 
开启 failback
 
·测试:
此时存储是在 DL-Server2上的
将 DL-Server2(主设备) 关机,可以查看到,存储已经自动切换到 CL-Server1 了
 
将 DL-Server2 开机:
可以看到,已经自动切换回来了:
 
 
 
 
 
三、配置 failover 配置 DFS服务器:
 
在两边同时添加两块磁盘,一块 1G,一块50G(这两块可以是iSCSI挂载过来使用的)
 
1、配置 磁盘:
不管该磁盘是通过什么方式挂载的,只要有两块磁盘即可
 
在两边 关机添加两块磁盘,一块1G作为仲裁磁盘,一块50G作为数据磁盘:
 
将磁盘格式化,并创建简单卷:
 
2、创建 集群:
集群会自动将空间小的磁盘用作仲裁磁盘,将空间大的磁盘用作数据磁盘
 
 
 
创建一个 failover 集群:
 
 
 
 
创建成功
 
·查看状态
使用 ipconfig查看,能够查看到有一个 tunnel接口 和 集群的ip:
如果一台机器没有集群IP,那么就是在另一台机器上
 
能够看到有两块磁盘:(一块仲裁磁盘,一块数据磁盘)
此时配置成功,只需要再加上 Hyper-V 即可
 
 
3、配置 DFS:
安装DFS:
 
在 failover 中创建DFS角色:
 
 
这里定义的名称会影响到DFS命名空间的名称
例如:这里定义的名称是:file,域名是:paris.com,命名空间的名称是:WSC2024
那么最后显示和访问就会是:\\file.paris.com\WSC2024
 
配置完成
 
·查看状态:
IP:
 
DFS:
 
 
四、failover集群配置 Hyper-V 虚拟机:
 
1、安装 Hyper-V:
Hyper-v 机器建议将内存和CPU调高,最好是 8G内存,4核CPU
需要先开启虚拟机的虚拟化功能:
 
 
 
 
安装后需要重启
 
 
2、设置 虚拟switch:
 
 
 
点击OK
 
 
 
3、打开 failover集群,创建 Hyper-V机器:
 
选择一个节点创建虚拟机:
 
 
将虚拟机的路径存储在 Failover磁盘中:
 
 
 
 
将磁盘路径存放在 Failover磁盘中:
 
本机挂载Window安装镜像,这里勾选使用镜像进行安装:
点击一下步,点击完成。
 
·如果有报错:
如果报错可能是因为和其它failover服务角色使用了同一块磁盘,再添加一块iSCSI磁盘到failover中即可
再添加一块iSCSI磁盘即可:
 
failover挂载该 iSCSI磁盘,将其格式化为简单卷:
 
然后再 failover中添加该磁盘:
 
最后再重复一次添加虚拟机的操作即可。