workfolder配置、修改workfolder端口.note

noteId: WEB8829105c906bb7f48f732ffaeaaa1f26 · 原始路径:/ALL/Windows - B模块/服务配置/ADFS+WAP+WorkFolder、Web反向代理/workfolder配置、修改workfolder端口.note · 图片:39 · 附件待处理:0

 
一、配置最基础的 workfolder
很简单的一个服务,跟NFS差不多,只需要加上证书即可
 
·注意事项:
workfolder会占用web的 80和443端口,如果本机还有web服务器,要么更改web的端口,要么更改workfolder的端口(这个较为麻烦)
 
 
1、申请一张web证书,并绑定到workfolder本机的 443端口上:
证书字段包含workfolder访问的url字段就行了,没有什么特殊要求
 
Web服务器不能够是启动状态,因为它跟workfolder端口是冲突的,如果web服务器是启动状态的,就代表workfolder没起来
这张证书需要绑定到Web的443端口
workfolder是什么端口,就需要绑定到哪个端口
 
 
2、配置workfolder:
 
安装 workfolder:
安装后需要重启
 
·注意:workfolder安装后需要手动启用服务,否则无法创建:
services.msc
 
 
配置workfolder的dns解析,操作这里不赘述
 
 
创建 workfolder共享:
 
输入路径:
 
默认
 
输入允许访问的用户组:
这里有两个是因为有两个域
 
勾选加密 workfolder:
 
点击完成即可
 
 
3、客户端连接workfolder:
control
 
 
 
点击连接
 
如果没有弹出报错,那么就是连接成功
然后一直点击下一步即可
 
此时workfolder就会出现在 文件资源管理器中:
 
此时你在其中创建的文件就会被同步到 workfolder服务器的根目录中,类似阿里云
 
创建文件:
 
右键点击立即同步:
 
在服务器上查看,能看到文件成功同步:
 
 
 
4、关闭WorkFolder连接:
 
 
 
二、更改WorkFolder的端口号
 
1、更改 WorkFolder端口:
 
(1)先停止 WorkFolder服务:
 
 
(2)修改workfolder配置文件:
我们没有权限修改该文件,需要取得所有权,并给予administrator修改的权限
# 路径:
c:\windows\system32\SyncShareSvc.config
 
先给予administrator写的权限:
 
 
然后编辑配置文件,修改端口号:
 
建议80 端口和 443端口都要修改,只改一个的话,另一个还是会冲突
 
最后需要输入一条命令才能生效
# 为Local SERVICE用户添加预存端口,允许他们监听指定的端口:
netsh http add urlacl url=https://*:1443/ user="NT Authority\Local SERVICE"
## 建议 80和443都修改,这样才不会和网站冲突
省略掉 NT Authority 也是可以的,会自动被补全
 
 
 
 
(3)同时修改 IIS服务器,Web服务器也必须要有一个相同端口号的 https接口:
必须绑定证书,这里绑定的证书是给 WorkFolder使用的
 
并且该网站不能启动:
 
 
(4)最后启动 workfolder服务:
如果服务启动失败,大概率是跟Web端口冲突了,停掉Web的站点即可