拨号(IKEv2预共享密钥).note

noteId: WEB607453f24fa9bda36423e339f8890a08 · 原始路径:/ALL/Linux - A模块/服务配置/VPN合集(openvpn、l2tp、wireguard)/StrongSwan(IPSec VPN GRE 站点到站点vpn隧道(Site-to-Site))/debian13新配置swanctl/IKEv2预共享密钥/拨号(IKEv2预共享密钥).note · 图片:27 · 附件待处理:1

 
 
肖老师之前的笔记:
 
一、IKEv2 预共享密钥(最简单可用):
 
·环境:
APP[192.168.10.1] - [192.168.10.254]GW1[1.1.1.1] - [1.1.1.10]Client
 
 
1、配置 服务端:
 
(1)安装软件包:
apt install -y strongswan strongswan-pki libstrongswan-extra-plugins
# strongswan-swanctl 在安装 strongswan 后会自动被安装
# libcharon-extra-plugins 在安装 libstrongswan-extra-plugins 后会自动被安装
 
 
(2)编辑 StrongSwan:
vim /etc/swanctl/
配置之前:
 
配置后:
 
结尾4个大括号
 
定义给VPN客户端分配VPN隧道地址的地址池:
 
设置预共享密钥:
 
(3)启用 StrongSwan:
swanctl --load-all
systemctl restart strongswan
 
 
如果配置文件错误会报错:no found
 
 
 
2、配置 客户端:
 
 
(1)安装软件包:
apt install -y strongswan strongswan-pki libstrongswan-extra-plugins
# strongswan-swanctl 在安装 strongswan 后会自动被安装
# libcharon-extra-plugins 在安装 libstrongswan-extra-plugins 后会自动被安装
 
 
(2)编辑 StrongSwan:
vim /etc/swanctl/
配置之前:
 
配置后:
 
设置预共享密钥:
 
 
·配置重启自动连接:
在 children 下修改三个参数:
当 start_action = trap 时,就仅会在有流量时才建立连接(但是当restart
strongswan之后,就会删除上一次的会话)
 
 
(3)进行拨号:
swanctl --load-all
swanctl --initiate -c net    //这个名称是我们children 下定义的名称
 
如果配置文件错误会报错:no found
 
进行拨号:
 
·查看:
可以看到,此时服务端分配了一个地址给客户端
服务端地址:
 
客户端地址:
 
此时客户端ping服务端内网就是完全通的,且本地不会出现路由:
 
 
·关闭隧道:
swanctl --terminate -c net