邮件分离.note
# 邮件分离就是 postfix 和 dovecot-iampd 不在同一台机器上,例如 postfix 在app1上,dovecot-imapd在app2上。
# postfix 服务器只安装postfix即可
# dovecot服务器需要安装 dovecot-imapd 和 dovecot-lmtpd使用 lmtp 协议
一、配置邮件分离:
1、postfix(app1机器):
apt install -y postfixvim /etc/postfix/main.cf
·模板:
postconf:


参数可以在 /etc/postfix/main.cf.proto中找到

vim /etc/postfix/master.cf
systemctl restart postfix
2、dovecot(app2机器):
apt install -y dovecot-imapd dovecot-lmtpdvim /etc/dovecot/conf.d/10-auth.conf


·在 debian 13.2下,auth_username_format要这样写:
但是默认就有一条,因此这里是不用写的(写也没影响)

vim /etc/dovecot/conf.d/10-master.conf

在 debian 13.2中,这里默认是 127.0.0.1,要改为 0.0.0.0
vim /etc/dovecot/conf.d/10-mail.conf
# 取消注释,并注释掉原本的:
## 这个配置是可选的
在 debian 13.2中已经没有mail_location 了
使用默认的无需修改:

# 这个没有变更:
vim /etc/dovecot/conf.d/10-ssl.conf
systemctl restart dovecot
如果有用户,就在 dovecot上创建,如果是连接ldap的用户,那么就在 dovecot上连接
·注意!!! 要设置 /home 目录权限为 777,因为ldap用户默认没有家目录,用户登陆邮件时会自动创建 mailbox,但是该用户没有权限写入 /home 就会报错
# 在 dovecot 上配置:
chmod -R 777 /home·客户端测试:



邮件发送成功。