配置 FTP AD域用户隔离.note
·首先先配置好 FTP
一、配置 FTP用户隔离:
用户只能访问自己的家目录,不能够访问其它目录
1、启用 AD域用户隔离:
(1)点击用户隔离:

(2)选择 AD域用户隔离,并设置凭据(凭据一般指定为 Administrator即可)


点击应用:

然后重启站点即可
二、再配置用户属性、创建用户家目录:
1、手动 设置用户的家目录(用户的家目录需要在 FTP根目录下真实存在,并且需要与用户名同名):
例如要使用 admin 进行测试,就需要在 FTP 根目录下 创建 admin目录(权限默认即可,无需修改)
(1)手动创建用户家目录:
mkdir c:\ftp\admin(2)手动 设置用户FTP属性(必须设置这两个属性,AD域用户隔离才会成功):
adsi、dsa.msc 中都能配置:
方式一:dsa.msc:(需要手动开启扩展)



方式二:adsi:
连接时使用默认的即可


2、使用 for 循环创建用户家目录、设置用户属性:
(1)使用 for 循环设置用户属性:
注意:必须要使用 单引号 ,否则会报错
FOR /F "tokens=1-10 delims=," %a in (C:\users.txt) do powershell set-aduser -identity %a -add @{'msIIS-FTPRoot'='C:\ftp'}
## 如果已经设置了属性,就需要使用 -replace
FOR /F "tokens=1-10 delims=," %a in (C:\users.txt) do powershell set-aduser -identity %a -replace @{'msIIS-FTPRoot'='C:\ftp'} (2)使用 for 循环批量创建用户家目录:
# 批量创建用户家目录:
FOR /F "tokens=1-10 delims=," %a in (C:\users.txt) do mkdir "c:\ftp\%a"
# 批量设置属性:
FOR /F "tokens=1-10 delims=," %a in (C:\users.txt) do powershell set-aduser -identity %a -add @{'msIIS-FTPRoot'='C:\ftp'} //注意需要使用单引号,使用双引号会报错三、测试:

而且不能进入其它目录